My PIVX wallet is not opening


#1

when I try to open my pivx wallet i get this message

pivx-qt.exe has stopped working

A problem caused the program to stop working correctly.
Windows will close the program and notify you if a solution is available.

please I need help

thanks.


#2

Don’t panic bro, just go into your PIVX install directory and rename the “blocks” folder for blocks_old. Then reopen the pivx-qt and it should be fine. (You will need to resync with the network, but all your funds will be there after the sync).


#3

I have a new install of PIVX core on Mac and it appears to be stuck synchronizing with the network. Its been in the same spot for about an hour. Any suggestions.


#4

go into:

~/Library/Application Support/PIVX

and check if the contents of the “blocks” folder are getting bigger. If yes, you just need to wait. It is the sync with the blockchain


#5

Im not finding anything PIVX related in the application support folder. The only thing I see for PIVX is the QT.app file in the application folder


#6

Any other info on how I can fine that blocks folder on a mac?


#7

Nevermind. I went through terminal and got it figured out. Thanks


#8

Having the same problem,

(( pivx-qt.exe has stopped working ))

But, my power went out as I was synchronizing the blocks for the first time.

Rebooted pc, reinstalled wallet twice, still can’t find into my PIVX install directory the “blocks” folder to rename to blocks_old.

Help


#9

if you are using windows just search for the “blocks” folder under windows search. If on MAC, then ~/Library/Application Support/PIVX. You can also quickly sync the blocks by downloading this: https://github.com/PIVX-Project/PIVX/releases/download/v2.1.6/Pivx_Blockchain_Backup-564385.zip

Then just the contents of the “blocks” folder with its contents.


#10

Jose,

Many Thx for the help… BUT, it didn’t work. I’ve searched with Windows search for blocks… Couldn’t find the “Blocks” file to rename. I’m still getting the error… (( pivx-qt.exe has stopped working ))

This is after doing a complete uninstall, and deleting “pivx” via reg-edit.

Then downloaded the wallet again, did a new install of the wallet, Running: Windows 64 Bit, Windows 7. SAME ERROR.

Here is my windows search…


#11

YES!!! I got my wallet to work.

I used Shbour’s YouTube video and reinstalled the blocks data.

I found the block data under the users appdata pivix

GO PIVX!!!

DASH = Coke & PIVX = Pepsi


#12

i have same problem doesnt matter what i do i cant make it work even when i reinstall it does the same can not oppen.


#13

Just had the same problem. So just so I understand you, I am to rename my “blocks” folder as “blocks_old”. After I do that, just re-open the app? Thanks.


#14

Ok I renamed block to block_old and I got it to work. Thank you! A few follow-up questions though. How does my wallet know my coin total? Is it solely from my wallet backup file for from the PIVX network? Also, sometime when I reopen my wallet, it says “blocks not loading, do you want to rebuild your blocks?”. I’m always thrown off by this, the first time this happened, I said yes rebuild and then the entire wallet went unstable and I had to reload all the back up files and start over. The second time this happened, I said no and it somehow worked anyway. Any thoughts? Thanks again…


#15

Your wallet knows your coin total by fetching its value right from the block chain. However, your public and private keys are held on the wallet.dat file and you should always backup this on external sources. Be sure to encrypt the wallet before right from the PIVX wallet interface. As for the blocks issue, you can also replace your current blocks files with the official block backup found on github.


#16

ATBTC how often should I backup my wallet.dat file to an external source? For example, I’m getting a lot of stake, almost a little each day, however, for some reason my block chain is getting corrupted, and then I have to replace my block files from GitHub. So now the issue is this: I woke up this morning and I had 10,360+ PIVX in my wallet, but then after I rebuilt my block chain I only have 10,330+. Some of the more recently minted staking is greyed out and says “Generated but not accepted”. This is so frustrating. Am I missing out on staking because the blockchain recognizes my stake, but when I rebuild my block file it’s referencing an old wallet.bat file? Thanks.


#17

Your wallet.dat only keeps the public and private keys for your wallet. So the only time in which you should update your backups is when you generate a new address to receive a payment. Every new payment or staking rewards are stored on already existant addresses on the blockchain.

Remember that your coins are actually on the public ledger, and the wallet.dat is simply a convenient way of storing public and private keys (addresses). As for the Generated but not accepted message, look for your public address on the blockchain explorer and you should see the REAL amount of your holdings: http://www.presstab.pw/phpexplorer/PIVX/index.php


#18

I have been using PIVX wallet on my iMac now for two days and it worked fine until I needed to restrat my computer and now it doesn’t open and only crashes. At first it said I had corrupted Blocks and now it just crashes without opening. Help anyone?


#19

It would seem like your blocks data got corrupt. If on MAC, then go to ~/Library/Application Support/PIVX and delete the contents of the blocks folder. Then replace them with the contents of this: https://github.com/PIVX-Project/PIVX/releases/download/v2.1.6/Pivx_Blockchain_Backup-564385.zip


#20

Thanks ATBTC.

I have the same problems with the 64-bit Linux client.

My experience is:

  • Install the client and wallet file
  • Add staking=1 to the pivx.conf file (the only entry in that file)
  • Start pivx-qt

All seems well. Unlock the Wallet for staking, the block index syncs after a period, and the staking in progress.

The green arrow hover text shows “Staking is active. MultiSend: Not Active”.

I cant’ find anything on MultiSend and if that is needed.

After 24hrs, minted coins arrive and all seems well.

However… any attempt to stop and start the pivx-qt client (gracefully, and using File > Exit), results in a corrupted block index.

Is this a known issue?

PIVX latest version, 2.1.6.