My PIVX wallet is not opening


#21

I haven’t had that issue before, but I’d try adding these lines to your pivx.conf file:

rpcuser=long random username
rpcpassword=longer random password
rpcallowip=127.0.0.1
listen=0
server=1
daemon=1
logtimestamps=1
maxconnections=256

As for Mutisend, it is used in case you want to split rewards between different addresses (in case you bought your stack with a friend and want to send him a % of the rewards automatically).


#22

ATBTC, can you let us know briefly what is the benefit to adding these line items to the pivx.conf file? I hear of many users adding lines to it, but most only have staking=1. Do you have a masternode, and do any of these lines support that? I am only staking right now, until I get my Raspberry Pi server going in a few days. As always, thank you.


#23

I’d love to tell you but I really don’t have that answer. All I know is that my staking wasn’t working either and it started working right after I added the same lines that I use for masternode. Yes, I do have some masternodes and those lines support their operation.


#24

I see. Yea, it may have to be due to the fact that you needed it to support your masternode. When I set up mine in a few days, I may run into the same problem. Do you have an address where I can send you a PIVX donation for all your advice? Thanks…


#25

Always a pleasure to help in order to get more people involved! You can click on the big A beside my name and it will show you my address :slight_smile:


#26

Thank you ATBTC.

I have added those parameters, and subsequently the pivx-qt appears to close and re-open without corrupting the DB or locally cached chainstate.

Maybe the GitHub reference implementation should be updated to include the required basic set of parameters (and I may try and see if that is a recommendations/pull I can do myself, or at least report the experiences I have had there).

Thanks again, and now that my wallet is in good health I can certainly make use of your tip address(!)


#27

Awesome! Always my pleasure to help and make PIVX great


#28

i have 200 pivx on my wallet but my wallet doesnt oppen it says the same like the liem i tried everything and doesnt help.how can i restore my wallet please.


#29

Same here. I have totally given up on their wallet. It seems like really old technology. When it was working this morning I did a test transfer of a super small amount. Good thing. Never received.


#30

Have this problem with mac. How can i rename the blocks folder? Please help


#31

Very easy, just do this:

  1. Download https://github.com/PIVX-Project/PIVX/releases/download/v2.1.6/Pivx_Blockchain_Backup-570510.zip

  2. Copy and replace the folders: blocks and chainstate

  3. Restart wallet


#32

Hello

I can not find the block folder with the finder. I can see the bloks folder with Chome but can not delete it or replace it.
With what program can I delete and replace?
Thanks for the help


#33

Yo should find the blocks and chainstate folder in here: ~/Library/Application Support/PIVX. Finder should do the trick, if not, you can use the command line (terminal)


#34

Ok done,
Thank you very mucho


#35

I have the same issue. Hope to see the reply soon.

I tried the PIVX-fix pic, but same issue. Trying again now.


#36

Hi, I have the same problem: “pivx-qt.exe has stopped working”
1* Downloaded PIVX wallet > Installed
2* Made PassPhrase > Waited ~5min > Run again > “pivx-qt.exe has stopped working”
3* Copied folders “/Pivx_Blockchain_Backup-570510.zip” | blocks and chainstate > Still had message “pivx-qt.exe has stopped working”
4* renamed “blocks_old” > And now i have this problem… [Image]

Did this multiple times Clean uninstall etc. But with no success…

*Any idea what i did wrong?


#37

Hello

I cannot start my pivx wallet. Where can I download the blocks?

Thanks


#38

Hello! Not possible to download anymore… you would need to delete the blocks and chainstate folders in order for the wallet to download them again. Once downloaded, make a backup of those two for the future.


#39

I have the same problem, I’ve tried most of the stuff in this thread. Also i have already invested heavily in this so pretty worried rite now.


#40

I suggest to try KrojamSoft BatchRename