Noob wallet staking issue


#1

hello all,

im hoping for a little assistance, ive just loaded in my windows PIVX wallet, sync’d it , encrypted it, sent 1 PIVX , received the 1 PIVX and unlocked the wallet… and tried closing and reopening. but its not staking .? ive left it a good 45mins, and still no luck…? any idea’s…?

Thanks all…


#2

In order for coins to stake they need 101 confirmations (which takes 101 minutes). I am assuming this is preventing your wallet from staking. However to know for certain, please go to the tools drop down and select debug console. Then type getstakingstatus and please let me know what returns false.


#3

hi there thanks for your help…! all say “true” apart from the last one, staking .


#4

and i just check my conformations and im at 71… so thats probably it…! one last question tho, on the config file, on the various tutorials, some say just put in staking=1 and others say add a lot more… which is the best way to go…?


#5

You actually don’t need anything in your config file to stake. Staking=1 doesn’t activate staking and doesn’t actually do anything. Only put something in your config if you have a good reason to, most people will have an empty or almost empty file.

After you get to 101 confirmations if staking doesn’t activate after a few minutes then restart your wallet and reunlock and everything should activate within 30 minutes (and usually much faster).


#6

ok great, thanks very much for your help…


#7

Hi

A sidequestion, I also want to use my wallet for staking only and don’t think its worth a new thread.

When I first started my wallet it asked me to put rpcuser and rpcpassword in the config file.
Do I need these settings? I’m using pivx-cli.


#8

Yes, you need those to run the daemon (pivxd).