PIVX Wallet 2.1.7 release


#1

New v2.1.7 Wallet Update

Official NON-MANDATORY (but highly recommended) v2.1.7 wallet update has been released with critical stability & bug fixes to address wallet instability reported by many users using prior versions.

NOTE: Due to some critical changes, it may attempt to re-index your current blockchain when you first launch the new wallet with your existing blockchain. If this fails, this means that your existing chain may be no good and you will need to resync from scratch to ensure you get a good copy of the blockchain from the network.

Changelog

  • Stability Fixes
  • Fix Re-Index
  • UI Transaction Sorting Update
  • Multisend Fix
  • Checkpoint added
  • Update Translations

How to Update
0. As always, backup the existing wallet to a safe location if you haven’t done so already.
(File -> Backup wallet or ./pivx-cli backupwallet)

  1. Download the appropriate wallet binary for your OS from link below.
    https://github.com/PIVX-Project/PIVX/releases/tag/v2.1.7
    For Windows users, I recommend “pivx-2.1.7-win64-setup-unsigned.exe” (or win32 if win64 fails)

  2. Overwrite the existing executable files with the newly downloaded wallet binaries.
    (This step is NOT needed for Windows users who download and upgrade via the above mentioned executable file)
    (For other OS users who require assistance in this area, please ask in #support channel in PIVX Slack for advice)

  3. Re-start the wallet. If prompted to re-index, then let it re-index. (or may do it automatically)

If #3 is successful and your wallet launches fine, you are done!
If #3 fails to re-index your blockchain or wallet fails to load, follow next steps:

  1. Close your current wallet. (File -> Exit or ./pivx-cli stop)

  2. From your data folder, delete the “blocks” and “chaninstate” folders. (Only those 2)
    (feel free to rename them as a temporary backup if you want but they aren’t critical)
    (default folder locations for each operating systen are listed below this guide)

  3. Re-start the wallet. Done! It will now take a while to resync back from the network.

Default Config / Data Folder Location
Windows:
Go to Start > Run
%APPDATA%\PIVX

OSX:
/Users//Library/Application\ Support/PIVX

Linux:
~/.pivx/


Windows updated without shutting down QT Wallet, now "Failed reading from database. mapBlockIndex" error now
#2

Are you guys releasing a QT wallet for Raspberry PI?


#3

Mac version: Installed the new version, no PIVX folder in application support, no blocks/chain folders, wallet out of sync by 1 year and 10 days, reindexing is not working and can’t find a blockchain backup anywhere. Reinstalled 4 times, still the same result. Please help. Thanks


#4

I cleared out all the files, reloaded PIVX with new wallet, synced with a clean blockchain. I backed up my wallet.dat beforehand but still receiving this error. When i use the base wallet that loads when application installs it is fine. Seems the wallet.dat backup is corrupt somehow? I removed just the two folders at first and when that didn’t work I went ahead and removed everything with a completely new install.

From the .db file

file wallet.dat has LSN 1/79290, past end of log at 1/333
Commonly caused by moving a database from one database environment
to another without clearing the database LSNs, or by removing all of
the log files from a database environment
DB_ENV->log_flush: LSN of 1/79290 past current end-of-log of 1/333
Database environment corrupt; the wrong log files may have been removed or incompatible database files imported from another environment
PANIC: DB_RUNRECOVERY: Fatal error, run database recovery
wallet.dat: unable to flush page: 57
txn_checkpoint: failed to flush the buffer cache: DB_RUNRECOVERY: Fatal error, run database recovery

From debug:

2017-04-14 05:10:12 *** System error while flushing: CDB : Error -30974, can’t open database
2017-04-14 05:10:16 CDBEnv::EnvShutdown : Error -30974 shutting down database environment: DB_RUNRECOVERY: Fatal error, run database recovery


#5

I have the same problem and no solution yet


#6

Ok guys, I think I finally found a fix.

My theory is that there are some PIVX files that just aren’t deleted out of the OS, “my problem was on Windows 7”, even though you think they were.

I was running an old version so I downloaded the 2.16 files off github to make sure everything matched up with my version i created the wallet.dat on, https://github.com/PIVX-Project/PIVX/releases

Then installed PIVX 2.16, on “a different PC” this happened to be my work PC. I also downloaded the block chain to make installation and syncing much quicker,
http://n-tw.net/dnet/chain.tar.gz

I copied and pasted the block chain files in the PIVX installation folder and let PIVX create a new wallet and install everything, sync up, completed and blue check mark showing.

I then closed PIVX, removed the wallet.dat file and replaced with my backed up wallet.dat file. Everything worked fine and I transferred my PIVX back to bittrex and going to just do a fresh wallet installation before transferring back.

I believed this was caused by a Windows update, and I also have a Wallet on a Windows 10 machine that does automatic updates, which scares the hell out of me, and thinking about switching it to Linux, which will be a pain, but no sudden updates would make me feel much better!

Also, I used an older backup copy of the wallet.dat than before. You should backup the wallet.dat frequently as an older version may be recoverable, but not the newer “corrupted” .dat file.

Try installing on a different PC, or if you are so inclined, reinstall your operating system and perform the steps above and you should be ok. I hope I can relieve the anxiety of somebody out there with there PIVX stuck in limbo.


#7

But what if I hadn’t time to back up my wallet on 2.1.6 ? I transferred some PIVX and during this time the error occured. How can I get hold of the transferred PIVX?


#8

This Windows wallet is acting up again.


#9

Your transfer should have ended up where it needed to go, as the transactions are very fast. If you didn’t have a prior copy of your wallet.dat you may want to try the wallet repair function in the wallet. That was my next move if the reinstallation on the different machine didn’t work.


#10

Gonna call a spade a spade… the windows wallet sucks. Still unstable.

I guess im grateful to the devs for making an effort… but this is people’s money we’re dealing with. An unstable, experimental POS currency riding on the coat tail of Dash, should’ve been thoroughly tested if it intends to compete.

I’ll play along a bit longer but i lose confidence in Private, Instant, Verified every time the wallet crashes


#11

Hi there guys,

I’m totally new here. So i’ve downloaded the latest wallet, got it to synch and stored some amount of pivx in there. As soon as I was going to make a backup and set up a password, the wallet crashed on me!
As I try to run the wallet, it crashes. I get these crash reports from my mac.

I’ve read about a way to change some files in certain folders with a blockchain backup file, downloadable at Github. It’s not there anymore and I believe it was for the 2.1.6 wallet after all.

I was hoping one of you guys know a way to get my wallet up and running again.

Thnkx


#12

hey

you have to delete the blockchain.
the folders “blocks” and “chainstate” in data dir (not sure where to find on mac, please see the first post in this thread).
just don’t delete your wallet.dat and backup this file as often as you can.

you can find a chain snapshot here: http://n-tw.net/dnet/chain.tar.gz
made 5 minutes ago with version 2.1.7 from one of my nodes.

extract the the file and copy “blocks” and “chainstate” to your data dir.
start the wallet and you should be fine

cheers


Trying to receive PIVX into my pivx wallet
#13

Hey guys,
thanks for the chain.tar.gz file. It worked on my Mac book pro 2.1.6 version. I have only another question. In the “Overview” -TAB I can see now my amount of PIVX but not anymore in the “Transaction” -TAB. Is that normal?
I appreciate your help.
Cheers


#14

do you mean the available/total amount? this amounts should only be visible in overview tab

afaik available/total amounts where never displayed in transaction tab only the amounts of the transactions

if you are missing transactions in overwiew/transaction you can run “tools” / “wallet repair” / "recover transactions 1 & 2 "

hope this helps


#15

Hey DRPD,
the “Available/Total” Amount is correct. I was only wondering whether in the “Transaction” tab there should be always proof for the made transactions

As you can see here it shows nothing. But before my wallet crashed the first time I could see my first transaction here.


#16

ahh ok you are right this tab should not be empty

please try the 2 repair functions, i guess this will help.

edit: wait you have selected “today” on first section, change this to “all” and your transactions will become visible!! :relieved:


#17

Oh yes :innocent: Champion!!! Thanks a lot.


#18

FYI: i will now update the chain snapshot at least twice a day with my ftp robot until we have a new official one on github.

@all: feel free to download the file if you need it, but please check the size first in case my ftpbot is in upload process (the file will be corrputed if you donwload while i upload :smirk:)

should be around 500mb


#19

Sounds great. Thanks DRPD.
One more question. Do I need to update to 2.1.7 ? Or should I stay with 2.1.6 now that it’s running again? Can I even update?
Cheers.


#20

you don’t have to update, but it is recommended.
on the other hand i guess there are some frustrating problems with mac wallet. i’m not sure cuz i only use win/linux

afaik there is a new update in works which will be mandatory. but version 2.1.7 is not mandatory, so you can leave it on version 2.1.6 if you prefer