[Unofficial][Newbie Friendly] Masternode Guide


#21

Things I would like to know before had setting up my masternodes.

1st - Your internet provider usually give you a single dynamic public IP, they are not fitted for run masternodes. In my case they refused to provide a fix IP. So the only solution was going after a VPS.
2nd - After setting up the masternodes starting them for the button on the wallet gave me the following message: Invalid IP address. However starting them through the debugging console works just fine.
3rd- Rewards take 5 days to show up.
4th- For real newbies like me, to execute the pivxd on the terminal you have to type ./ before the file name.


#22

@slimjim If you haven’t figured it out yet, slack me


#23

Thank you for this, I’m gonna certainly incoporate this in the support faq/website


#24

I am going crazy trying to get pivxd to start on reboot.

I have made a crontab which does makes it start, but then i get this error:

PIVX server starting
Error: Unable to bind to 48.71.32.77:51472 on this computer (bind returned error Cannot assign requested address (99))
Error: Failed to listen on any port. Use -listen=0 if you want this.

If I start it manually I don’t get this error, only when crontab tries to start it.

Any idea why? I have made sure port 51472 is open so its not that.


#25

https://pivx.freshdesk.com/support/solutions/folders/30000053113 Heres updated tutorials. Try removing bind= from the masternode’s pivx.conf


#26

Awesome! Yes that worked!
I’m a bit worried it might brake something though? Is that bind= line redundant then?
So to help others - To get crontab to restart pivxd on reboot I did this:

sudo crontab -e

added this line:

@reboot cd ~/pivx-3.0.6/bin && ./pivxd

And I removed this line from the masternode’s pivx.conf:

bind=YOURSERVERIP

You also need to start the cron service - because it’s not on by default on some VULTR’s servers.

Another Issue I had was starting the masternode from the controller wallet.
Clicking the buttons - Start Alias, Start ALL, Start Missing - NONE of them worked!
I could only start the masternode after I went to Settings>Unlock Wallet
And then I did startmasternode missing from the debug console.
THEN IT WORKED!

Phew… this little bit of info would have saved me 24 hours!!!