Updated EDITED Raspberry pi Masternode setup


I actually re-did my masternode and I’m having the same problem now too. Not sure why it does this. If i find a solution, I will report back. In your case though, it might be due to not being able to make a DHCP reservation or port forward.


Something to try: instead of clicking on your masternode and clicking start alias, instead go in the debug console on your controlling wallet and type in masternode start-many.

For some reason the controlling wallet messes up with the GUI starting of a masternode and instead works better with going into the debug console and starting it that way.

That got it going for me. I’m going to edit this into the guide


Nice guide! I just wanted to fill you guys in that the development team is aware of a bug with the linux version of the pivx-qt wallet which causes crashes after some time, and it should be fixed in the next version. For now, pivxd and pivx-cli are preferred for stability (though it looks like you’ve already discovered this ;))


Thank you for the info! Yep, seems like pivxd in command console is the way to go.

I’m not too sure if its a pivx-qt problem or just lack of ram for raspberry pi.

I remember I tried running pivxd in the command console while having my raspbian OS running and it still crashed over time.

I assumed it was more of a ram issue at that point since the raspberry pi3 only has 1gb of ram and the OS I believe takes up a good amount of ram to just be open.

Also the maxconnections= x needed to be set to 8-12 for mine to not overload.

Hopefully this adds to the devs knowledge :slight_smile:


EVERYONE, for specific questions, i would highly recommend joining the PIVX discord channel and go to the support tabs. There are always people there active and always helpful!


many thx for that guid, hepled a lot.
I just wanna point out that I had problems without adding the port only on the bind parameter, I had to do it also on the masternodeaddr parametr to get the node proper working.

bind= XXX.XXX.X.X:51472
masternodeaddr= XXX.XXX.XXX.XXX:51472