Wallet won't open Mac OSX High Sierra


#1

Hi,
My wallet 3.0.6 (high sierra only) won’t open. It shuts down after the logo, . The same happened hen i installed 3.0.5.1. Do you have any suggestions?
here is the report: Process: PIVX-Qt [1306]
Path: /Applications/PIVX-Qt.app/Contents/MacOS/PIVX-Qt
Identifier: ???
Version: ??? (???)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: PIVX-Qt [1306]
User ID: 501

Date/Time: 2018-01-24 17:54:24.350 +0200
OS Version: Mac OS X 10.13.2 (17C205)
Report Version: 12
Anonymous UUID: 10657311-4DE6-9F2F-6163-A260BB221A5A

Sleep/Wake UUID: AD0DAF76-D0F3-4E24-96DE-0D2C32BD9403

Time Awake Since Boot: 1000 seconds
Time Since Wake: 220 seconds

System Integrity Protection: enabled

Crashed Thread: 9 QThread

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Application Specific Information:
Assertion failed: (hashPrevBlock == view.GetBestBlock()), function ConnectBlock, file /Users/spock/spock_PIVX/src/main.cpp, line 3273.


#2

i should mention that i have deleted the blockchain folder and it’s still the same


#3

I would try these steps:

Close the wallet
Rename the pivx data directory folder, the folder with the block chain and the wallet.dat file.
Open the wallet
If successful the wallet will act like a new install.
Close the wallet
Move your wallet.dat back into the newly created pivx data directory
Restart your wallet.

Please let me know if this works. Remember don’t delete files/folders just rename


#4

thank you. so far it worked. i am now waiting for the sync to finish


#5

Hold on… what is a “pivx data directory folder”??? You lost me on this step.


#6

When you first ran the wallet one of the steps asked you where you wanted the wallet to store the files that the wallet generates (theblockchain, wallet files, configuration, etc.). This location is the data directory and for most users would be located here:

https://pivx.freshdesk.com/support/solutions/articles/30000004664-where-are-my-wallet-dat-blockchain-and-configuration-conf-files-located-


#7

Thanks, thuggins. My PIVX app actually opened and didn’t crash on the 4th try, so I don’t need to try to repair anything right now. But if I get crashes in the future and can’t get past them, I’ll come back here and try what you said. Thanks.