What's new

Upgrade from PIVX Core Wallet 2 to Version 4

kiwi

New Pivian
Hello,

I had an old PIVX Version 2 wallet on this computer. At an additional computer I have a PIVX wallet (with the same wallet.dat) in Version 3, but I did not upgrade the wallet.dat file.

Now on this computer i installed the new PIVX core wallet. At start I get the message: "Error at Initialisation of the wallet database" ("Fehler bei der Initialisierung der Wallet Datenbank Umgebung ....".
The path is correct. But the wallet files are from Version 2.

What must I do for upgrading/migration?

Thanks for help.
 

Jeffrey

Administrator
Staff member
Hi @kiwi It's recommended that when updating from a much older PIVX installation that you remove your blockchain files and resync. Never delete any wallet.dat always keep multiple backups.

Use the snapshot here: https://snapshots.pivx.org/ and follow the guide on the same page. This will speed up your sync dramatically.
 

kiwi

New Pivian
Hello, thanks for your response.

In the moment I am dowloading the zipped blocks.
What was the reason for the error message?
 
Last edited:

kiwi

New Pivian
Hello @Jeffrey ,
today I found some time to work with the issue. I downloaded the snapshot and started the pivx-qt client. The same error accurs...
After OK at the error message the client closes itself.
What can I do?
 

Jeffrey

Administrator
Staff member
Did you delete all the blockchain files to do a resync?

Basically delete everything except for:
  • Wallet.dat
  • backups
then open your PIVX wallet.
 

ghostcat

New Pivian
Hi @Jeffrey , I too also have the same problem with with PIVX wallet. I also have an old PIVX wallet and decided to upgrade to the latest one. I have made backups of the critical files (as stated in the thread). I've done it before when I've done the incremental upgrades of the wallet, and I've not have had any problems. Unfortunately, it's been almost a year and a half since I've opened the wallet, so I know that I am WAY behind in the wallet versions. I've downloaded the latest wallet, and downloaded the latest blockchain, around a couple of weeks old (didn't have a chance that time). But now when I tried to do it, it says "error in opening the blockchain" and the client closes.

Any help please?
 

ghostcat

New Pivian
Hi @Jeffrey , I also saw your previous post regarding resyncing first an old PIVX-QT wallet from another user. Here was the link:


Unfortunately, I followed the instructions in this current thread first, instead of opening up my old PIVX QT wallet and resyncing it. Is there a way to download the old PIVX QT first again and force to resync again from scratch? This was the one you posted about the instructions:


Thank you.
 
Top